Algoritmo para crear potencias, números factoriales y hallar la media aritmética.

Ignacio

Publicado por Ignacio

-MEDIA ARITMÉTICA, POTENCIA Y NÚMERO FACTORIAL-

(ALGORITMOS)

 

Hoy vamos a plantear y resolver los ejercicios algorítmicos

correspondientes a la media aritmética, potencia y número factorial.

Plantearemos los algoritmos propuestos por los profesores y los nuestros

propios para proceder a su resolución. Comencemos:

 

        ALGORITMO PROPUESTO POR EL PROFESOR

 

INICIO

Suma:=0

Cuenta:=0

Mientras que (Cuenta<100(en este caso))Entonces

Leer Num

Suma:= suma+num

Cuenta:= cuenta+1

FMientras

Escribe:”La media aritmética es “Suma/Cuenta”;

FIN

 

 ALGORITMO PROPUESTO POR NOSOTROS:

Proceso Media_Aritmetica (1)

         Definir a,b,c,d,e, producto, mediaritmetica Como Entero; (2)

         Leer a; (4)

         Leer b; (6)

         Leer c; (8)

         Leer d; (10)

         Leer e; (12)

         producto<-a*b*c*d*e; (13)

         mediaritmetica<-(a+b+c+d+e)/2; (14)

FinProceso (17)

 

                   EXPLICACIÓN CÓDIGO:

 

1: Definimos el proceso o programa

2: Definimos los valores, el producto y la media

Del 1 al 12: Escribimos los números y valores y el programa los lee.

13: Hallamos el producto de los 5 números.

14: Hallamos la media.

15: El programa nos muestra el mensaje y el resultado

16: Finaliza el proceso

 

     ALGORITMO POTENCIA  (2 NÚMEROS)

 

 

 ALGORITMO PROPUESTO POR EL PROFESOR

INICIO

 Num1

 Num2

Resultado:=1

 num2=(no) Entonces

Resultado:=resultado num1

Num2:= num 2-1

Escribe “La potencia vale” resultado

FIN

 

           ALGORITMO PROPUESTO POR NOSOTROS:

 

  Proceso Potencia (1)

         Definir base, exponente, potencia Como Entero; (2)

    Leer base; (4)

    Leer exponente; (6)

    potencia <- (base)^(exponente); (7)

FinProceso (9)

 

                       EXPLICACIÓN CÓDIGO:

 

                1: Definimos el proceso o programa

                2: Definimos las variables base, exponente y potencia como

                Valores numéricos.

               3: Esta variable está escrita para que haga un salto de línea. Si el

               “Sin Saltar” fuera al final del proceso (Final de la expresión), no

                Haría ningún salto de línea.

              4: Lee la base.

              5: Leo mismo que en punto 3 pero con exponente.

              6: Lee el exponente.

              7: Realiza la operación de potencia con la base y el exponente.

              8: Escribe el resultado de la potencia y lo muestra.

  

                        ALGORITMO NÚMERO FACTORIAL

 

ALGORITMO PROPUESTO POR EL PROFESOR

INICIO

Leer num

Factorial:=1

Num1=(no)0 entonces

Factorial =factorial*num1

Num1=Num1-1

Resultado: “El factorial sería “factorial”

FIN

 

            ALGORITMO PROPUESTO POR NOSOTROS:

  

           Proceso factorialConRepetir (1)

                   Definir contador, n, factorial Como Entero; (2)

                   contador <- 1; (3)

                   factorial <- 1; (4)

                   Leer n; (6)

                   Repetir (7)

                            factorial <- factorial * contador; (8)

                            contador <- contador + 1; (9)

                   Hasta Que contador > n (10)

         FinProceso (12)

 

                         

 EXPLICACIÓN CÓDIGO:

1: Nombre del programa o proceso

                    2: Definimos los valores como resultado numérico

                    3 y 4: Es una variable que realiza el proceso de hallar el                     número 5.

                 5: Escribimos el número.

                 6: El programa lo lee

                7 ,8 y 9: El programa se inicia con el producto del número y el  contador 1.

               10: El contador llega al resultado final.

               11: El programa escribe el resultado del factorial.

 

               12: El programa finaliza.

¿Te ha gustado? Compártelo
Ignacio

Ignacio ver perfil

Profesor en Tusclasesparticulares

Imparte clases de informática, Otros, Cine y audiovisual y Dibujo

Síguenos en
© 2007 - 2019 Tus clases particulares Mapa web: Profesores particulares| Academias y centros