Algoritmo para sumar números indeterminados, hallar el mayor y el menor y cuántas veces se repite un número

-SUMA DE INDETERMINADOS, MAYOR O MENOR, “OCURRE”-

(ALGORITMOS)

Hoy vamos a realizar la siguiente lista de algoritmos, los cuales son: La suma de números indeterminados, hallar el número mayor o menor que y cuantas veces ocurre que se repita un número. Comencemos:

ALGORITMO SUMA NÚMEROS INDETERMINADOS

ALGORITMO PROPUESTO POR EL PROFESOR:

INICIO

Resultado:=0

Leer Cuantos

Cuantos=(no) 0 Entonces

Num

Resultado:= resultado+num

Cuantos:=cuantos-1

Fmientras

“El resultado es” resultado

Fin

ALGORITMO PROPUESTO POR NOSOTROS

Proceso Sumanumerosindeterminados (1)

Definir A, B, C, D, Resultado Como Entero; (2)

Leer A; (4)

Leer B; (6)

Leer C; (8)

D <- A+B+C; (9)

FinProceso (11)

EXPLICACIÓN CÓDIGO

1: Nombre del proceso o programa

2: Define las variables, el número indeterminado y el resultado como Entero

Del 3 al 7: Nos pide que escribamos el valor de las variables (O dicho de otro modo, los números) y el programa los lee.

8 y 9: Expresión que realiza la suma y halla la cantidad de números que tenemos (En este caso los 3 números) y halla el resultado.

10: Muestra el resultado en pantalla.

11: El programa finaliza.

ALGORITMO MAYOR Y MENOR (NÚMERO)

ALGORITMO PROPUESTO POR EL PROFESOR:

INICIO

“Introduce un número”

Num

Mayor:= Num

Menor:=Num

Contador:=Num

Contador=(no) 100 Entonces

Num

Num>Mayor entonces mayor:= num

num< menor entonces menor: num fsi

Contador:= contador+1

Fmientras

“El menor número es” menor

“El mayor número es” mayor

Fin

ALGORITMO PROPUESTO POR NOSOTROS

Proceso mayormenorigual (1)

Definir A,B,C,D,E, Resultado Como Entero; (2)

Leer A; (4)

Leer B; (6)

Leer C; (8)

Leer D; (10)

Leer E; (12)

Si A<B Y A<C Entonces (13)

FinSi (15)

Si B<A Y B<C Entonces (16)

FinSi (18)

Si C>A Y C>B Entonces (19)

Sino (21)

Si D>A Y D>B Entonces (23)

Sino (25)

Si E>A Y E>B Entonces (27)

Sino (29)

FinSi (31)

FinSi (32)

FinSi (33)

Si A<B Y A<C Entonces (34)

Sino (36)

Si B<A Y B<C Entonces (37)

Sino (39)

Si C<A Y C<B Entonces (40)

Sino (42)

FinSi (44)

FinSi (45)

FinSi (46)

FinProceso (47)

EXPLICACIÓN CÓDIGO

1: Nombre del proceso o programa

2: Definimos las varables y el resultado como Entero

Del 3 al 12: Vamos metiendo números y el programa los va leyendo

Del 12 al 45: El programa entra en un bucle condicional que va realizando y hallando los números que son mayores y menores entre si y, luego después, da su resultado final.

47: El programa finaliza

ALGORITMO CUANTAS VECES OCURRE

ALGORITMO PROPUESTO POR EL PROFESOR

INICIO

“Introduce el primer número”

Num

Antes:= num

Contador:=1

Cuenta:=0

contador=(no) (<) 100

Entonces

“Introduce número”

num

num > antes entonces cuenta:=

Cuenta+1 Fsi

Contador:=Contador+1

Antes:=num

Fmientras

“Ha ocurrido cuenta”

Fin

ALGORITMO PROPUESTO POR NOSOTROS

Proceso kRepetido (1)

Definir i,n,nk,k,cont Como Entero; (2)

n<-0; (3)

cont<-0; (4)

Leer n; (6)

Leer k; (8)

Para i<-0 Hasta n-1 Con Paso 1 Hacer (9)

Leer nk; (11)

si nk=k Entonces (12)

cont<-cont+1; (13)

FinSi (14)

FinPara (15)

FinProceso (17)

EXPLICACIÓN CÓDIGO:

1: Define el nombre del programa como una lista de ciclos repetidos

2: Define los ciclos, los números que metamos, el contador y el resultado como Entero

Del 3 al 6: Escribimos la cantidad o los números que tenemos y escribimos el ciclo para que nos diga cuanto se repetirá.

Del 7 al 11: Creamos el ciclo que irá cumpliendo las condiciones hasta que se vaya cumpliendo todo. Es un bucle que cumple la función de ciclo.

Del 12 al 14: El proceso finaliza

15 y 16: Muestra en pantalla las veces que se repite un número y nos muestra el mensaje en pantalla. Después, el proceso finaliza.

Temas
© 2007 - 2022 Tus clases particulares Mapa web: Profesores particulares| Academias y centros