Curso Excel BForm. Andrés Botín Formador . Función SUMAR.SI

FUNCIÓN SUMAR.SI

La función SUMAR.SI. de Excel nos va a permitir realizar la suma de determinados rangos de celdas que cumplan una condicion o criterio.

Sintaxis de la función

=SUMAR.SI(rango;criterio;[rango suma])

En dónde:

rango es el conjunto de celdas que queremos comprobar si cumplen el criterio o condición.

criterio es la condición que tienen que cumplir las celdas para ser sumadas.El criterio irá entre comillas y usaremos los operadores de comparación: > (mayor que) , < (menor que), >= (mayor o igual que), <= (menor o igual que), <> (distinto). Podemos comparar números o textos. Algunos ejemplos de criterios:

Menor que 3000 -->"<3000".

Mayor o igual a 5000 --> "<=5000"

Distinto de 5800 --> "<>5800"

Igual a 6200 --> "6200"

Igual al texto PAGADO ---> "PAGADO"

Distinto al texto PAGADO --->"<>PAGADO"

rango suma( es un parámetro opcional) es el rango de celdas que queremos sumar.

Cuando el rango de celdas a comprobar y el rango de suma sean el mismo, solo bastará con escribir la función con dos parámetros, es decir,SUMAR.SI(rango;criterio).

Veamos un ejemplo:

Tenemos una serie de empleados con un saldo y una comisión. Queremos calcular la suma de los saldos de los empleados que tienen saldo negativo(menores que 0).

Para ello usaremos la función SUMAR.SI., en este caso el saldo va a ser nuestro rango y también el rango de suma , por lo tanto emplearemos la función con 2 parámetros:

rango-->C3:C12 y criterio --> "<0"

Nuestra función quedaría:

=SUMAR.SI(C3:C12;"<0")

Nos da el resultado de -19.150.

Ahora calcuralemos el saldo de los saldos postivos(mayores que 0).

rango-->C3:C12ycriterio-->">0"

Nuestra función quedaría:

=SUMAR.SI(C3:C12;">0")

El resultado de los saldos positivos es 34.169 euros.

Si queremos sumar de las comisiones cuyo saldo sea positivo (mayor que cero), tendremos que usar la función SUMAR.SI con tres parámetros.

Ahora el rango de criterios será el saldo C3:C12 , ya que queremos sumar solo los que cumplan el criterio mayor que cero(positivos), y el rango de suma, es decir los valores que queremos sumar serán las comisiones que se encuentran en el rango de celdas D3:D12.

rango criterio-->C3:C12

criterio-->">0"

rango suma --> D3:D12

Nuestra función quedaría:

=SUMAR.SI(C3:C12;">0";D3:D12)

La suma de las comisiones con saldo positivo es 13.221

Criterios de tipo texto

Ahora vamos a utilizar criterios de tipo texto. Supongamos que queremos calcular el importe total de los clientes que han pagado en la siguiente hoja.

Para calcular el importe cobrado usaremos la funcion SUMAR.SI con el criterio de tipo texto "SI" , que indica que ese importe se ha cobrado, de la siguiente manera:

=SUMAR:SI(D4:D15;"SI";C4:C15)

En dónde rango de criterios es D4:D15, y escribiremos un SI si se ha cobrado, y un NO si no se ha cobrado.

El criterio es el valor de tipo texto SI que indica que se ha cobrado la cantidad.

Y el rango de la suma es C4:C15.

Nos da un total de 1.102 euros cobrados.

Si queremos calcular el importe total no cobrado, podemos usar dos técnicas

1- Colocando en criterio el valor "NO"

=SUMAR:SI(D4:D15;"NO";C4:C15)

2- Usando como criterio el valor "<>SI" (distinto de si)

=SUMAR:SI(D4:D15;"<>SI";C4:C15)

Que nos da un total de 1.221 euros pendientes de cobro.

© 2007 - 2021 Tus clases particulares Mapa web: Profesores particulares| Academias y centros